Home Forums Troubleshooting Color correction settings not sticking

This topic contains 7 replies, has 5 voices, and was last updated by  Jvarney 3 years, 10 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #827


    Hey, I ::think:: I read something about this on tc forums, but dont recall what the solution was… I’m hoping someone will be able to fill me in here.

    I am attempting to take an animation (digitized to the TM) and adjust the color settings thru the properties menu of the clip. When I do this, the clip adjusts settings until it is finished playing (once the timeline moves off that particular clip). When I scrub back over the clip, or begin playing from the begenning, the color correction settings are gone. I have to go back into the properties menu, and click on the “settings” button (the “use” button is already selected and hilighted). Once I go back into the settings, the color correction takes effect. However, I must do this EVERY time I wish to play the clip… And since I cannot get it to load automatically… I cant get the begenning part of the animation to play with proper color correction.

    Any help with this would be appreciated.

    Also, I noticed that when I attempted to drag my color picon into a bin, I cannot drag and drop it back in order to reset the color settings to what I had stored in the picon. Am I doing this correctly? I thought it was supposed to work the same as any other picon.

    I am using the latest version of the software (2.7 I believe) and all problems are appearing in the editor part of the software (haven’t tried anywhere else). I am looking into re-digitizing the animation thru the switcher with the color correction settings, altho I’m not sure this will work.




    If you have things set up right-and it sounds like you do, then you just click on that clip to “wake up” the color settings for. (This is only an issue on the “pro” portions of the color correction.) Also make sure that you have set up the same correction for both input channels in the correction panel. (Click on the number in the upper left, usually 1 & 2, or 2 & 3, etc.)

    If there are different settings in one timeline, you can position the staus bar in the middle of one of them and then click on different clips to select its color correction properties. As you highlight each one that has the “use” button enabled the clip’s outputed still will change, if the “use” button is not enabled not change will take place-so you can see if you have the settings right. Currently only one (pro) setting can be played out per timeline, so if you have more that one clip corrected and the settings are different, then you have to put it to tape in more than one step. (Clicking on a clip to set the proper correction for each segment.)

    The picons don’t grag and drop back in (yet?). But you can use them in Switcher to do it that way if you wish.

    There is a detailed discussion of this in a file I have-if I can find it…



    Thanks for the reply petes!

    After a bit of troubleshooting on my end, as well as contacting GS, this is a basic rundown of what I tried, and the final stuff that we did to get it working.

    I had tried using both tape color correction and nle color correction, both seemed to have the problem. (I think I did the NLE color correction first, but I’m not 100% positive) For some reason, it wouldn’t stick until I went in and opened up the settings panel, then it would work until the timeline went past, at which point I’d have to close down the settings, and re-open the settings pannel to get it to work properly again.

    What appears to have been the problem is the order I was doing things. I spoke with a GS tech, and we went thru step by step what I should/shouldn’t do and everything works. What he had me do is: select the clip, go to it’s properties, enter the color correction setup, make the adjustments THEN hit the use button. I had previously hit the use button before making my settings… which is the best guess the two of us could come up with as to what was causing the problem.

    So far, making settings changes and then afterwards clicking on the use button seems to have fixed my problem. Unfortunately, we didn’t find any way to drag the picons back onto the settings panel to revert saved settings in the editor.

    Thanks again for your help petes…

    I ended up having other problems with the project, due to myself still learning the system, and trying to swap between animator, switcher and editor. Seems things work differently in each part of the program… but I’m figuring it out! (I think)



    I guess that makes sense. You set the levels, THEN hit “use”.
    I guess I lucked out and have always done it that way. I’m glad you found this. Thanks.



    It’s not the order of operation as far as I can tell, it works either way for me. It’s something else in your process that was the problem.



    This may not be relevant but I remember getting this from one of the hardware engineers and thought it might help in some way…

    “…this is kind of weird, but it seems to work for me. Color correction can be divided into two types, “proc. amp controls” (hue, saturation, luma & setup) and more “deluxe functions” (the limit buttons, white & black hue & magnitude, and all Pro Color Corrector settings). The “proc. amp” functions do work as expected, and can be changed clip by clip. The current software does kind of work to allow “deluxe” settings on NLR playback, but only for one setting (other than normal) per timeline. That is, you can’t have one clip with the settings to make it more blue, while another clip is set to make it more red. The “deluxe” correction logic can be setup as per the adjustments, and then merely turned on or off on a clip by clip basis. It can’t be changed while the timeline is playing. (Of course you must have SDI or component cards for TM playback, or one of each).

    Now, here’s the weird part. For some reason, the software doesn’t see the limiting buttons as part of the color corrector, even though they are. (this is also true for all the “pro” color corrector settings) So, although they are turned on when setting them, when the clip is encountered when playing the timeline, the software “forgets” to enable the “deluxe” logic. So, what I’ve done is just to set some other parameter, say “setup” to 0.1% (which does nothing, really). Now the software recognizes that here is a color corrector setting there, and turns it on for the clip(s)! Remember also, that the NLR color correction “use” button must be set on.

    Now, there’s still a bit more involved in making this work right. During transitions, the TM uses the input module directly behind the TM board, and for some reason the settings don’t get made to that board correctly. So, when you open up the clip properties to setup the NLR color corrector, notice that the input module board selected is the “N+1” board (“N” being the slot your TM board is in). To get it to work right during transitions, make sure the settings are the same for the “N” board (one less than the default number when opening the panel). You may have to click on something (a setting) and hit return for the values to actually be entered. Now it should work right!

    Just one other thing. Although the settings are saved with the timeline, they aren’t loaded properly when you restore it (you’ll notice this next time you restart). In that case, right-click on one of the color corrected clips, select “setup” for NLR color correction and it will enter them in. Now, do it for the “N” input board also, and you’rein business.

    It’s a little clunky, but it works. I’ve especially needed this when correcting some scenes that were shot with the camera white balance set to “indoor” when the cameraman returned outside (and forgot to change it). Hope this helps you out,


    Mike Haskell

    How does the $5000 for the upgrade fix this issue?




    I was only doing the standard color correction (hue, saturation, etc), so I dont think this fits under the same problem or not.

    I went back and attempted to re-create the problem, and couldnt!!! I dont know if it was just a glitch or something.. but I had actually restarted editor, restarted the computer and the globecaster itself (this before posting my problem here).

    Something the GS tech and I talked about fixed it, however… When I asked him what I did wrong, the only thing we could see that was different was the “use” button after adjusting settings. so… that was our best guess as to what caused it, but I’m honestly clueless, since I cant re-create it.

    Oh well, it’s working now… I cant complain.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Stay Up to Date on News and Upgrades

Whether one of the first or one of the newest in the GlobeCaster family, we will drop you a line from time to time.